2013年05月24日

bundle install でインストールしたnokogiriが動作しない

bundle install でインストールしたnokogiriが次のようなエラーどうも動作しない。

WARNING: Nokogiri was built against LibXML version 2.9.1, but has dynamically loaded 2.7.8


どうもMountain lionのLibXMLがサーバーのものとちがうのが原因らしい。一度bundleの内容を削除して

rm -rf ./vendor/bundle/*


bundle configを変更

bundle config build.nokogiri --with-xml2-dir=/usr/local/include/libxml2 --with-xslt-dir=/usr/local/include/libxslt --with-iconv-dir=/usr/local/Cellar/libxslt/1.1.26


再度bundle installでインストールすればok

bundle install --path=vendor/bundle


posted by ねこまんま at 10:53 | Comment(0) | TrackBack(0) | サーバー | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント:


この記事へのトラックバック
×

この広告は1年以上新しい記事の投稿がないブログに表示されております。